Thales Simulator Service don't read my config.

Apr 7, 2011 at 9:38 PM


 have a problem with the ThalesServiceSimulator.

It installs without any problem and runs OK with the standard configuration.
When I do changes in the ThalesParameters.xml file the Service still run with the standard values.

It is installed on an XP in “c:\program\NTG\Thales Simulator Service”.
I change the ThalesParameters.xml file to use
<Port value="8099" />
<ExpectTrailers value="True" />
<HeaderLength value="50" />

I also changed the ThalesServiceSimulator.exe.config to point at the config
<add key="ParameterFile" value="C:\Program\NTG\Thales Simulator Service\ThalesParameters.xml"/>

 I have also tried the service on a Vista with the same result.

 What do I need to do to make the Service accept my configuration?

 Thanks // Jajjeboj

Apr 8, 2011 at 7:49 AM

In ThalesParameters.xml, change the VBSourceDirectory and XMLHostDefinitionsDirectory and assign a value of "C:\Program Files\NTG\Thales Simulator Service". Also copy all XML host command definitions in the "C:\Program Files\NTG\Thales Simulator Service" directory. Please let me know if that fixes the problem.

Apr 8, 2011 at 8:40 PM

Thanks for the quick answer.
It fixed the problem.

Just one minor thing. 
The consol command QH shows header lenght 04. 
I have configured 50.
I use 50 from the TCP client and it works as it should.

Connected - Type in commands followed by ENTER.
Message header length: 04
Protocol: Ethernet
Character format: ASCII
IP address:
Well-Known-Port address: 8099

Thanks // Jajjeboj


Apr 9, 2011 at 6:02 AM

You're right, my oversight. Fixed and uploaded. Thanks for spotting that.